Agent bei eingehenden Mails mit Problemen bei "NonDelivery Report"

  • Hallo,


    wir haben eine Notes-Applikation, die unter anderem auch Mails versenden und empfangen kann.
    Der Empfang refulärer Mails funktioniert einwandfrei, so wie es sein sollte.
    Bei Eingang der Mails wird ein Agent aufgerufen, der die Mails analysiert und entsprechende Funktionen ausführt.
    Nun wollten wir den Agenten erweitern um auch "NonDelivery Report"-Mails auswerten zu können.
    In der Konsole können wir sehen, dass die "NonDelivery Report"-Mails an die DB übergeben wurden und der Agent auch wunschgemäß gestartet wurde.


    Jetzt kommt das Problem:
    Die "NonDelivery Report"-Mails tauchen nirgendwo in der DB auf.


    Was passiert da? Im Domino-log können wir sehen, dass die "NonDelivery Report"-Mail an die DB übergeben wurde und dass der Agent entsprechend getriggert wurde. Der Agent kann jedoch die "NonDelivery Report"-Mails nicht finden.
    Es wird keinerlei Dokument in der DB für das "NonDelivery Report"-Mail angelegt.


    Vielen Dank für eure Hilfe.


    Gruß Thorsten

  • Hi,


    Und was macht der Agent?
    Wi sollen dei Mails denn angezeigt werden?
    Passt eventuel das Selectionskriterium fuer die 'neuen' Gegebenheiten nicht mehr?


    Ohne weitere Kenntnisse ist das aucs meiner Sicht jetzt ein Ratespiel mit der Kristallkugel.



    Andreas

  • Hallo Andreas,


    es werden definitiv keine Dokumente in der DB für eingehende "NonDelivery Report"-Mails angelegt.
    Der Agent macht gar nichts, da er keine Dokumente findet.
    Wir haben eine Liste, die alles sortiert nach dem Feld "form" anzeigt. So haben wir feststellen können, dass keine "NonDelivery Report"-Mails in der DB sind.
    Alle anderen Mails tauchen in der DB wie erwartet auf und werden auch alle perfekt verarbeitet.


    Gruß Thorsten


    P.S. ein Selektionsproblem kann ich für's erste ausschließen, da keine Dokumente in der DB sind, die selektiert werden könnten.

  • HI,


    Eigentlich wollte ich mit meinem Post nur zum Ausdruck bringen, das es sehr schwer ist irgenwelche Vermutungen ueber die Ursache des Problems anstellen zu koennen,
    ohne zu kennen, was der Agent tut.


    - Prueft der Agent irgenwelche Felder, die es in einem Non Delivery Report nicht gibt.
    - Prueft er den Namen der Maske (Form) und der Non Delivery Report ist nicht mit dabei
    - speichert der Agent die eigehenden Dokumente


    Es gibt so viele moegliche Ursachen was das Problem sein koennte.


    Grob gesagt, ohne den Aufbau des Agenten zu kennen...


    Und auch schon mal versucht den Agenten ein wenig zu 'debuggen'. (z.B. ein paar print-Anweisungen einbauen. Die kannst Du dann im Log verfolgen)



    Andreas

  • Hallo Andreas,


    das Problem ist nicht, was der Agent macht oder nicht macht.
    Das Problem ist, dass er nichts machen kann, da keine Dokumente in der DB sind obwohl das Domino-Log sagt, dass eine entsprechen Mail zugestellt wurde.


    Gruß Thorsten



    P.S. Der Agent registriert lediglich Absender und Empfänger

  • HI,


    Dann frag ich doch mal ganz einfach.


    Wie ist der Agent denn getriggert.
    - before new mail arrives
    - after new mail has arrived


    Und woher weiss der Agent, welche Dokumente er verarbeiten muss.
    - unprocessed documents
    - selection from a view



    Andreas

  • Wenn der Router sagt, er hat die Mail zugestellt, kann man erst einmal davon ausgehen, dass das auch stimmt. Wenn der Agent anläuft, dann erst recht.
    Stellt sich also die Frage, wie du überprüft hast, dass das Dokument augenscheinlich nicht vorhanden ist. Hast du mal mit Werkzeugen wie bspw. scanEZ die DB geprüft?
    Hast du mal den Router angehalten, um so einen NDR in der mail.box zu überprüfen, ob das Dokument in Ordnung ist?


    andreas : wenn der Agent anläuft, wenn der Router die Mail zustellt, tippe ich der Logik halber einfach mal auf "before"... Und "UnprocessedDocuments liefert bei dem Trigger "None" zurück, siehe Hilfe.
    Wenn der Agent ansonsten wie gewollt tut, bleibt nur noch eine View, die er anpiekt.

    Life is not a journey to the grave with the intention of arriving safely in a pretty and well-preserved body, but rather to skid in broadside, thoroughly used up, totally worn out, and loudly proclaiming "Wow, what a ride!!! :evil:
    Beschleunigung ist, wenn die Tränen der Ergriffenheit waagrecht zum Ohr hin abfliessen - Walter Röhrl

  • RockWilder ,


    Dem stimme ich ja auch zu, aber bisher sind hierueber noch keinerlei Informationen preis gegeben worden.
    Also muss man ja erst einmal ganz simpel anfangen zu fragen.


    Ausser der allgemeinen Aussage das keine Dokumente angelegt werden.
    Und das kann ich mit folgendem Beispiel vergleichen.
    Ich rufe in der Autowerkstatt an und sage, mein Auto springt nicht an. Koennen Sie mir sagen was ich tun kann/muss, damit es wieder anspringt.



    Andreas

  • RockWilder und ascabg


    Es gibt nicht mehr Informationen.
    Die Datenbank beinhaltet ca. 10 Dokumente - also durchaus überschaubar.
    Wie ich in der Eröffnung schon geschrieben habe, haben wir eine Liste, die alle Dokumente sortiert nach dem Feld "form" anzeigt.
    Wenn nun also ein neues Dokument in der Datenbank auftaucht, dann sollte (muss) es auch in dieser Liste zu sehen sein.
    Alle normalen Mails laufen in der DB mit dem Wert "memo" im Feld "form" auf - nur eben die "NonDelivery Report"-Mails laufen nicht auf.
    Ich habe zwischenzeitlich einfach mal den Agenten deaktiviert und mehrere "NonDelivery Report"-Mails ausgelöst.
    Im Domino-Log wird angezeigt, das die Mail zugestellt wurde. In der DB tauchen diese aber nicht auf.
    Das Problem kann also nicht am Agenten liegen, da dieser nun auch nicht mehr im Spiel ist.

  • Wie gesagt: mit Spezialwerkzeug solltest du es nochmal versuchen.
    Bei 10 Dokumenten unwahrscheinlich: aber vielleicht ist der Ansichtsindex einfach nicht aktuell, dass du den NDR nicht siehst? Wie sieht denn die Selection Formula der Ansicht aus?
    Was passiert, wenn du eine brandneue Ansicht anlegst, die auf @All selektiert?


    andreas : ich gebe dir da ja Recht, so allgemein gehaltene Informationen lassen Raum für Interpretationen. Wesentlich mehr waren meine Vermutungen auch nicht. No offense meant!

    Life is not a journey to the grave with the intention of arriving safely in a pretty and well-preserved body, but rather to skid in broadside, thoroughly used up, totally worn out, and loudly proclaiming "Wow, what a ride!!! :evil:
    Beschleunigung ist, wenn die Tränen der Ergriffenheit waagrecht zum Ohr hin abfliessen - Walter Röhrl

  • In der Ansicht werden alle Dokumente angezeigt - SELECT @All..
    Eine zweite Ansicht, die auch alles selektiert ändert nicht am Ergebnis.
    Am Ansichtsindex kann es eigentlich auch nicht liegen, denn dann würden auch die regulären Mails nicht angezeigt werden.
    Die Anzahl der Dokumente ändert sich bei normalen Mails, nicht aber "NonDelivery Report"-Mails.

  • Dann stelle ich mal die Behauptung auf, dass die Mals dann auch nicht in der betreffende Db eingehen.


    Mal ganz einfach gefragt.
    Du sagst, dass die Applikation auch Mails versendet. Wer ist denn der Absender der Mails? (denn nur auf versendete Mails kann ja auch ein NDR erfolgen)



    Andreas

  • Absender ist ein Agent bzw. kann ich dies natürlich auch von jedem beliebigen Mail-Client machen, solange die Absendeadresse stimmt.
    Wie schon gesagt, die entsprechende Meldung taucht im Domino-Log auf und wenn der Agent der DB aktiviert ist wird dieser auch getriggert. Es wird jedoch kein NDR-Dokument in der DB abgelegt, sodass der Agent ins leere läuft.

  • Nein, ist nicht.
    Das war auch schon mein Verdacht, da die NDRs ja einen $REF-Eintrag hätten.


    Unabhängig davon müsste sich die Anzahl der Dokumente in der DB ändern, sobald ein NDR-Dokument angelegt wird.



    Ich hab' zwischenzeitlich schon den Verdacht, dass an der DB irgendwas zerschossen ist.

  • Für alle Interessierten.


    Es lag nicht an der DB, an einer Ansicht oder an dem Agenten.


    Ein Neustart des Router-Task brachte Ruhe.
    Anscheinend lag das Problem im Router. Nach einem Neustart funktioniert alles so wie es soll und gedacht war.


    Ich danke trotzdem für die Hilfe und die Tipps.


    :danke: