Beiträge von EIZO

    Hallo zusammen,


    ich habe folgendes Problem:


    Unsere iPhones werden mit MobileIron verwaltet und nutzen die native Mail-App.


    Folgendes Problem:

    Wenn der User eine gesendete Mail in LN zusätzlich in einen Ordner schiebt, sieht er die Mail wie immer auch im Ordner in LN aber nicht im Ordner auf dem iPhone.


    Auf dem iPhone selbst habe ich erst gar nicht die Möglichkeit, eine gesendete Mail zusätzlich in einen Ordner zu verschieben.


    Wenn ich in LN eine neue Mail mit "Senden und ablegen..." sende, ist es das gleiche:

    Die Mail ist in LN außer unter "Gesendet" auch im zusätzlichen "Senden und ablegen..." -Ordner, aber wird nicht im iPhone angezeigt.


    Dies ruft natürlich sofort die Notes-Gegner auf den Plan (das sind die meisten), denn mit MS-Exchange und Outlook mit iPhone und native App funktioniert das alles.


    Ist das ein Traveler-Problem, od. wird das von LN, bzw. Traveler einfach nicht unterstützt ?


    Auf meinem Android-Handy, daß nicht über MobileIron verwaltet wird, nutze ich die Verse-App, aber damit fuktioniert es auch nicht.


    Ist das überhaupt bekannt? Gefunden habe ich dazu nichts.


    Vielen Dank schon mal im voraus für eure Tipps.


    Gruß

    Siggi


    Domino 9.0.1FP10 HF383

    Traveler 10.0.1.0 Build 201811191126_20

    Danke für die Formel.

    Ich bin leider kein Profi wie Du vermutl. ;-)


    Das Bsp. von Tarec lautete:

    1. @If (From = "Hans Dampf";
    2. @Do(
    3. @AddToFolder ("Testordner"; "($Inbox)");
    4. @MailSend ("Test3 Test3"; ""; ""; Subject; "Neuer Maileingang."+ @NewLine +"Bitte klicken Sie auf die Verknüpfung um das Dokument zu öffnen."; ""; [IncludeDoclink])
    5. );
    6. "")

    Und dann funktioniert´s eben nicht.


    Aber jetzt weiß ich wie es auch mit

    Code
    1. @Contains(@LowerCase(@Name([Abbreviate] funktioniert.
    2. Danke Dir

    So der Fehler war folgender:


    Ich wußte nicht, daß bei "From" der Name komplett so wie er im From-Feld steht, angegeben werden muß:

    Bsp:

    @If (From = "CN=Hans Dampf/O=Test/C=DE";


    Dann funktioniert´s auch.


    Also:

    @If (From = "CN=Hans Dampf/O=Test/C=DE";

    @Do(

    @AddToFolder ("Testordner"; "($Inbox)");

    @MailSend ("Test3 Test3"; ""; ""; Subject; "Neuer Maileingang."+ @NewLine +"Bitte klicken Sie auf die Verknüpfung um das Dokument zu öffnen."; ""; [IncludeDoclink])

    );

    "")


    Bei extern prüfe ich auf das Feld "SMTPOriginator".

    Bsp:

    @If (SmtpOriginator = "extern@t-online.de";


    Also:

    @If (From = SmtpOriginator = "extern@t-online.de";

    @Do(

    @AddToFolder ("Testordner"; "($Inbox)");

    @MailSend ("Test3 Test3"; ""; ""; Subject; "Neuer Maileingang."+ @NewLine +"Bitte klicken Sie auf die Verknüpfung um das Dokument zu öffnen."; ""; [IncludeDoclink])

    );

    "")


    Sollte ich es z.B. auf einen internen und externen Absender prüfen wollen:


    @If (From = "CN=Hans Dampf/=Test/C=DE" | SmtpOriginator = "extern@t-online.de ;

    @Do(

    @AddToFolder ("Testordner"; "($Inbox)");

    @MailSend ("Test3 Test3"; ""; ""; Subject; "Neuer Maileingang."+ @NewLine +"Bitte klicken Sie auf die Verknüpfung um das Dokument zu öffnen."; ""; [IncludeDoclink])

    );

    "")



    Meine Tests funktionieren jetzt genau so wie es sein soll.

    Dann sollte es auch mit der produktiven externen E-mail Adresse funktionieren.


    Ich danke Euch für eure Hilfe und Geduld.

    So funktioniert´s leider gar nicht mehr :-(

    Die Mail bleibt einfach im Maileingang und sonst passiert nichts mehr....

    Na ja, natürlich nicht im Produktivbetrieb :-)

    Hintergrund:

    Wir werden zukünftig auf diese Mail-In-DB von einem Kunden mit immer dem selben Absender Mails bekommen,

    die dann eben in den "Testordner" verschoben und aus dem Maileingang gelöscht werden sollen.... aber eben nur bei diesem Absender.

    Es kommen auch noch Mails von andern Absendern in diese Mail-in-DB.

    Die sollen aber auch im Maileingang bleiben.

    Moin,


    es ist ein ganz normaler Agent in einer Mai-In-DB.


    Wenn der Absender "Hans Dampf" ist, soll er die Mail aus dem Maileingang löschen und in den "Testordner" verschieben

    und anschließend eine Mail mit Link an den User "Test3" senden.


    Funktioniert auch alles super, nur daß auch Mails von andern Absendern ebenfalls in den "Testordner" verschobenen, und aus dem

    Maileingang gelöscht werden.


    Siggi

    Hab´s gerade nochmal nach [IncludeDoclink]); mit ""; versucht, funktioniert aber auch nicht:


    @If (From = "Hans Dampf");

    @AddToFolder ("Testordner"; "($Inbox)");

    @MailSend ("Test3 Test3"; ""; ""; Subject; "Neuer Maileingang."

    + @NewLine +

    "Bitte klicken Sie auf die Verknüpfung um das Dokument zu öffnen."; "";

    [IncludeDoclink]); "";

    Hallo zusammen,


    folgende Formel macht eigentl. genau das was es soll, nur:

    Es werden nicht nur die Mails von "Hans Dampf" in den Testordner verschoben, sondern jede Mail, egal welcher Absender.


    Was mache ich falsch?


    SELECT Form = "Memo";

    @If (From = "Hans Dampf");

    @AddToFolder ("Testordner"; "($Inbox)");

    @MailSend ("Test3 Test3"; ""; ""; Subject; "Neuer Maileingang."

    + @NewLine +

    "Bitte klicken Sie auf die Verknüpfung um das Dokument zu öffnen."; "";

    [IncludeDoclink])


    Wäre nett wenn ihr mir helfen würdet.

    Hallo zusammen,


    ich habe in einem Dokument u.a. 2 Felder zur Auswahl:


    Ort (Optionsfeld) und ein Textfeld (Kommentarfeld).


    Ich hätte gerne folgendes:
    Wenn ich Ort "A" auswähle, soll im Textfeld automatisch z.B. Rot als Textfarbe verwendet werden, bei Ort "B" z.B. Grün.


    Ist das möglich?
    Habe zumindest nichts dazu gefunden.


    Vielen Dank im voraus für eure Hilfe.

    Und was sind das in meinem PDF? .....ich glaube Screenshots ?(
    D.h., wenn ich den Text direkt gepostet hätte, und im PDF nur die Screenshots wären, wäre das ganze i.O. gewesen?


    Ach komm ...... :S



    RockWilder:
    Ich bin leider kein Profi wie Du, kenne aber dennoch die Taste F1 die ich auch benutzt habe.
    Leider habe ich das mit @UserRoles nicht richtig verstanden, sonst hätte ich ja eure Hilfe nicht in Anspruch genommen.


    Erst der Hinweis von Taurec


    "Schau dir einfach mal das Beispiel in der Notes Hilfe zu @UserRoles an. Dort siehst du daß du @IsMember bzw @IsNotMember verwenden musst."


    hat mich auf die richtige Spur gebracht:


    4. Dieses Beispiel gibt 1 zurück, wenn dem aktuellen Benutzer sowohl die Rolle [WebTeam] als auch die Rolle [ManageFiles] zugewiesen ist. Es gibt 0 zurück, wenn dem Benutzer nur eine oder keine der beiden Rollen zugewiesen ist.
    @IsNotMember("[WebTeam]":"[ManageFiles]";@UserRoles)


    Das ganze ist doch langsam lächerlich oder?
    Laßt uns das Thema beenden :D


    Ich entschuldige mich 1000 mal für diesen eklatanten Fehler und gelobe Besserung.


    Ich wünsche eine gute Nacht :sleeping:

    Schau dir einfach mal das Beispiel in der Notes Hilfe zu @UserRoles an. Dort siehst du daß du @IsMember bzw @IsNotMember verwenden musst.


    Generell meinte Torsten damit, daß du das was du im PDF zusammengefasst hast auch hier einfach direkt im Editor schreiben kannst ohne den Umweg über ein PDF.


    Das macht es leichter zu lesen


    Vielen Dank für den Hinweis.
    Jetzt funktioniert´s.


    @IsNotMember("[Schulungskalend]";@UserRoles)



    Ich habe Torsten schon verstanden.
    Aber:
    Es kommt immer wieder vor, daß es heißt "Gib uns mehr Infomationen".
    Darum dachte ich mir, ich mach´s gleich richtig und liefere ein paar Bilder mit.
    Denn wie schon gesagt "Bilder sagen mehr als tausend Worte".


    Dazu nochmal die Frage:
    Warum kann man dann überhaupt ein pdf hochladen?
    Macht irgenwie keinen Sinn ...


    Beim nächsten mal mach ich´s dann hoffentl. richtig ;-)


    Danke nochmal.

    Tut mir Leid, ich dachte Bilder sagen mehr als tausend Worte ;-)


    Ich hab jetzt nochmal versucht, das ganze in einem .pdf in Wort und Bild zu fassen.
    Ich wüßte sonst nicht, wie ich es anders erklären sollte.
    Solltest Du damit nicht klarkommen.... kein Problem.
    Ich versuche dann unseren Dienstleister (für solche Fälle) zu erreichen.


    Vielen Dank im voraus.


    Das .jpg kann ja dann gelöscht werden.