Beiträge von lodsnods

    Vorsicht bei der Installation von Fixpack 8 unter Domino 9.0.1. Da ist ein Bug drin versteckt, der unter Umständen dazu führt, daß Anhänge bei ausgehenden Mails beschädigt werden.
    In dem befreundeten Forum
    gibt es hierzu schon einen längeren Thread.Falls Ihr das also installieren wollt, solltet Ihr anschließend einmal eine Mail ins Internet schicken und schauen, ob alle Anhänge anschließend noch lesbar sind.

    Hallo Taurec,


    bin gerade im Urlaub, aber mein Kollege hat wohl gerade einen logische und erfolgversprechenden Ansatz gefunden.
    Auf dem Traveler bzw. einem der Dominos ist wohl noch die "Adreßsuche auf lokales Verzeichnis beschränkt" eingestellt, so daß die Authentifizierung schon aber das Mailrouting nicht funktioniert.


    Überlappungen in der Hierarchie bzw. "doppelte" Nutzer in beiden Adreßbüchern sind eher nicht das Problem ...


    [Nachtrag]
    Traveler läßt die Mail über den Homserver des Absenders versenden.
    Auf dem einen Server war tatsächlich noch die "Adreßsuche auf lokales Verzeichnis beschränkt".
    Hier kurz korrigiert und den Roter neu gestartet -> läuft
    [/Nachtrag]

    Hallo,


    ich habe hier ein Problem mit dem Mailrouting des Traveler in einer etwas komplizierteren Installation (Domino jeweils 8.5.3 FP2, Traveler 8.5.3.2, alles Linux)


    - es gibt 2 Firmen mit unabhängigen Dominos (org_a@dom_a und org_b@dom_b)
    - darüber ist eine Meta-Org für zentrale Dienste (Sametime, Traveler, etc), nennen wir sie meta@meta
    - die Firmen kennen sich alle 3 untereinander und die Server haben auch Zugriff aufeinander
    - meta hat eine Verzeichnisverwaltung (Notes + LDAP) mit den Verzeichnissen aus dom_a und dom_b
    - darüber funktioniert auch erfolgreich die Anmeldung der Traveler Nutzer
    - dom_a kennt auch das Verzeichnis von dom_b (und umgekert) über eine Verzeichnisverwaltung (Notes + LDAP)
    - Notes Mailrouting klappt auch zwischen alle 3 Domänen (Adressen werden per F9 auch korrekt (incl. Notes-Domain) vervollständigt)
    - so weit - so gut und alles so, wie hier bei IBM beschrieben


    Ich habe nun folgendes Problem:
    Ein nutzer_a aus dom_a versendet per Traveler eine Mail an einen nutzer_b in dom_b. (bzw. auch andersherum)
    Die Mail sehe ich auch auf server_a ankommen, doch dort scheitert die Auslieferung


    nutzer_b/dom_b not found in domino directory


    Was ja prinzipiell auch stimmt.
    Leider erkennt der server_a nicht, das er nutzer_b im per Verzeichnisverwaltung bekanntgemachten verzeichnis_b finden könnte.
    Bei einer Mail im Notesclient hingegen erkennt er dies durchaus problemlos.


    Wie kann ich jetzt
    a) den Traveler überreden, die Mail an nutzer_b/dom_b@dom_b zu senden (mit angegebener Notesdomäne funktioniert das Mailrouting) oder
    b) den Traveler überreden, die Mail gleich auf server_b abzuliefern oder
    c) den Domino überreden, seine Verzeichnisverwaltung korrekt auszuwerten?


    Oder ist das möglicherweise ein Bug im Traveler?

    AAAHHHHH JA
    da bin ich doch wieder mal auf die Werbung reingefallen :-)


    Zitat

    IBM Lotus Notes Traveler-Software ist eine Push-E-Mail-Lösung, die schnellen Zugriff auf E-Mails (einschließlich Anhängen), Kalender, Adressbuch, Journal und To-do-Liste für mobile Lotus Notes-Benutzer bietet.
    Quelle: IBM Lotus Traveler


    Von 4 unterstützten Plattformen können das nur 2 und das auch nur halb (nur Server zu Endgerät)


    Trotzdem Danke - da kann ich ja die Suche einstellen ... ;(

    Hi,


    wir haben hier einen Domino 8.5.3 mit dem Traveler 8.5.3 unter Linux laufen. Funktioniert auch soweit alles gut.
    Ich frage mich jetzt nur, wohin das Journal synchronisiert wird?


    Auf meinem Androiden kann ich es jedenfalls nirgendwo entdecken ...
    Bei den Richtlinien habe ich ein entsprechendes Einstellungsdokument angelegt - bei dem Android-Client sehe ich nur Einstellungen zur Synchronisierung von Mail, Kalender und Kontakten - von Notizbuch finde ich nichts.


    Wo also landen meine Notizen?

    Hi,


    ich habe mich mit der ID Vault noch nicht so intensiv auseinandergesetz, glaube mich aber zu erinnern, daß der Abgleich der IDs nicht sofort bein Start des Notesclients passiert, sondern in einem Kulanzintervall von einigen Minuten. Das soll die Server morgens vor zu viel Traffic schützen.


    Evtl. hilft es Dir ja, wenn Du nur die Notes.id in das Userhome des Nutzers legst und nicht das gesamte Notes Data Verzeichnis. Das geht ja recht elegant über einen Eintrag in der notes.ini


    KeyFileName=N:\irgendwo_aufm_Server\user.id

    Hallo,


    ich habe bei einem Kunden das Problem, daß sich der Notesclient (8.5.1 unter Windows 7 64 bit) häufig beim Löschen von Dokumenten "verabschiedet". Das Notebook wurde schon mal bereinigt und Notes neu installiert - danach lief es auch wieder eine ganze Weile, jetzt kommt der Fehler aber wieder.


    Bei IBM habe ich schon ein paar Einträge (siehe hier und hier) gefunden, die das gleiche Problem beschreiben, ohne bisher allerdings eine Lösung gefunden zu haben.



    Ich hatte auch schon den Verdacht, daß sich der Virenscanner hier irgendwie über das Ziel hinausschießt - der läuft aber auch auf all den anderen Clients ohne Probleme :-(

    Hi,


    noch ein kleiner Nachtrag.


    Hatte gerade ein ähnliches Problem mit Update vom FP2 HF284. Der Installer kam mir auch mit "Not valid Domino Version was detected 852HF284".


    Nachdem ich ein
    export LANG=de_DE.UTF-8


    abgesetzt hatte, konnte ich (nachdem ich in der script.dat Servername und Servertyp eingetragen hatte) mit


    ./install -script script.dat


    das Fixpack zwar nicht installieren, dafür hat das Installscript mich komplett zurückgebeamt auf einen 8.5.2er Server ohne Fixpacks. Ein erneuter Aufruf von


    ./install -script script.dat


    hat mir dann das FixPack 3 installiert.
    Bein Update meckert das Script eine fehlende strings.dat unter /opt/lotus/notes/latest/linux an, bei mir lag diese jedoch unter /opt/lotus/notes/85020/linux/res/C/strings.res. Die strings.res sollte man sich vorher also wegsichern ...

    Hi,


    es gibt nur eine Kennwortrichtlinie (und die wirkt meiner Meinung (und auch der admin Hilfe) nach nur auf die notes.id), die eine Passwortlänge von 5 Zeichen verlangt. Die Passworter liegen da deutlich drüber.


    Das Passwort habe ich vorher initial im Personendokument geändert ("Pass_001") und den HTTP restartet. Ich kann mich mit dem Passwort auch anmelden und rufe dann mit "?ChangePassword" den Änderungsdialog auf und ändere das Passwort auf "Pass_002". Der Request landet auch in der Admin4, stirbt dort aber bei der Verarbeitung mit "falschem Kennwort". Als ob der Passwort-Change-Request einen anderen Passwort Hash Alg. verwendet als der Domino-Server ...


    Ich habe dazu mittlerweile bei IBM ein Ticket aufgemacht. Mal sehen, was die Jungs und Mädels dort zu dem Thema herausfinden.

    Hi,


    auch mir ist es in meinen zahllosen Migrationen bisher nur einmal passiert, daß es mit einer Anwendung Probleme gab. Es war ein Gruppenterminkalender, der sich durch alle DBs gehangelt und die Daten in einer zentralen DB konsolidiert hat.


    Die Anwendung wurde im Zuge der Migration aber sowieso abgelöst, so daß ich nicht genau sagen kann, woran es letztendlich lag. Ein Rechteproblem ist aber nicht auszuschließen.


    Probleme kann es auch geben, wenn die Anwendung externen Code aus DLLs einbindet, wie es früher öfter mal der Fall war (z.B. das F1 Toolkit, daß schon unter R4 Schleifen in der Formelsprache ermöglicht hat). Wenn sich die Programmierung aber auf Notes Boardmittel beschränkt, sind keine bösen Überraschungen zu erwarten ...

    Hi,


    ich bin da gerade auf ein Problem mit Domino 8.5 gestoßen.
    Ein Nutzer meldet sich im Web an (8.5er Mail Schablone) und versucht sein Passwort zu ändern bzw. wird durch ein Eintrag in seinem Personendokument dazu gezwungen.


    In dem Passwort Dialog gibt er sein altes Kennwort und das Neue (2x) ein und kann normal weiterarbeiten. Die Passwortänderung wird an den Admin4 weitergeleitet und schlägt dort bei der Verarbeitung sinngemäß mit dem folgenden Fehler fehl:


    Aktion:
    HTTP-Kennwort im Domino Verzeichnis ändern


    Aktion angefordert von: Domino/Server
    Server, der die Anforderung bearbeitet: Domino/Server
    Beginn: 14:12:57 Heute
    Ende: 14:12:57 Heute
    Verarbeitete Datenbanken: None


    Fehler:
    Title: Firma Path: names.nsf; Error: Falsches Kennwort.
    (Beachten Sie die exakte Schreibweise des Kennworts in Bezug auf Gross- und Kleinschreibung.)


    Wobei "falsches Kennwort" an dieser Stelle definitiv gelogen ist ....

    Hi,


    ich kenne den Travelerclient für das iPhone nicht, aber bei dem "normalen" Travelerclient auf meinem Nokia kann ich getrennt für


    Mails,
    Kalender und Aufgaben,
    Kontakte,
    Notizen


    einstellen, ob und für welchen Zeitraum diese abgeglichen werden sollen.


    Und wenn es clientseitig nicht konfigurierbar ist, gibt es ja immer noch ein passendes Traveler-Einstellungsdokument bei den Richtlinien im Adressbuch. Auch dort kann man einstellen (Mail, Kalender, Augaben, Kontakte, Journal), was synchronisiert werden soll.

    Hi,


    ich habe zwar schon einige Zeit nicht mehr programmiert, würde mir aber das NotesItem holen und dort mit item.appendToTextlist die Werte bzw. Mehrfachwerte eintragen (Häkchen setzen).


    Ggf. mußt Du noch die üblichen Probleme "fixen", wenn Du das Dok im UI offen hast, aber im Backend daran rumfummelst ...

    Hi,


    was siehst Du anders? Es ist genau so, wie es Taurec sagt und in der Hilfe steht:


    - die Nachricht geht nicht an den originalen Empfänger
    - die Nachricht wird in die Ziel-DB kopiert
    - die Nachricht wird nicht (!!!) in die Inbox (oder einen anderen Ordner) verlinkt
    - die Nachricht erscheint somit nur in den Ansichten (z.B. alle Dokumente)



    Hallo,


    ich habe hier einen etwas seltsamen Effekt - nicht dramatisch aber verwunderlich


    Domino 8.0.2 unter Linux (SLES 32 bit)
    QuadCore CPU, 4GB Ram, 4 GB SWAP
    auf der Maschine läuft nichts anderes


    Der Domino zieht den gesamten RAM (soweit ok, cachen soll er ja) und zusätzlich 2 GB SWAP. Da ja SWAP in meinen Augen auch nur "langsame Platte" ist, dachte ich mir, mit einer Speichererweiterung hier etwas Performance rauskitzeln zu können. Also flink nochmal 4 GB nachgesteckt und übers Wochenende laufen lassen. Zu meiner Verblüffung ergibt sich nun folgendes Bild:


    Von den 8GB RAM werden nun alle 8 GB benutzt und von den 4GB SWAP werden jetzt auch alle 4 GB benutzt. Das Swappen wollte ich ja eigentlich mit der Speichererweiterung vermeiden ...


    Ein 7.0.2er Server unter SLES 9 zeigt so ein Verhalten nicht. Er krallt sich "nur" den gesamten physikalischen Speicher, läßt aber wunschgemäß die Finger vom langsamen SWAP.


    Liegt das jetzt an der Betriebssystem- oder an der Dominoversion?


    PS: das mehr an Arbeitsspeicher macht sich jedenfalls positiv bemerkbar. Unsere 7GB Monster-CRM-DB flegt wieder förmlich :-)