Beiträge von smet

    Hallo zusammen,


    bei uns sind noch alte Domino Server in der Version 6.5.6FP3 im Einsatz, da es noch alte Anwendungen auf Basis von Lotus Workflow 3.0 gibt.


    In den Workflow Applikationen wurde u.a. Java im Background Agent genutzt. Beim Start des Agenten werden diverse Meldungen ausgegeben, die immer mehrere Seiten Logeinträge im Log des Domino Servers erzeugen. Sie sind zwar als Error Messages angegeben, aber die Applikationen laufen fehlerfrei. Ich nehme an, die Meldungen werden von der JVM des Servers ausgegeben. Gibt es eine Möglichkeit, diese Meldungen zu unterbinden? Das Log-Level des Agent Managers steht bereits auf 0.


    Beispieleintrag Domino-Log:


    22.04.2013 14:30:43 Agent error: [Loaded JavaAgent]
    22.04.2013 14:30:43 Agent error: [Loading superclasses of JavaAgent]
    22.04.2013 14:30:43 Agent error: [Loaded TripBilling]
    22.04.2013 14:30:43 Agent error: [Loading superclasses of TripBilling]
    22.04.2013 14:30:43 Agent error: [Loaded AutomatedActivityAgentTemplate]
    22.04.2013 14:30:43 Agent error: [Loading superclasses of AutomatedActivityAgentTemplate]
    22.04.2013 14:30:43 Agent error: [Preparing JavaAgent]
    22.04.2013 14:30:43 Agent error: [Preparing AutomatedActivityAgentTemplate]
    22.04.2013 14:30:43 Agent error: [Loaded WFBinder]
    22.04.2013 14:30:43 Agent error: [Loading superclasses of WFBinder]
    22.04.2013 14:30:43 Agent error: [Preparing WFBinder]
    22.04.2013 14:30:43 Agent error: [Loaded GlobalVoucher]
    22.04.2013 14:30:43 Agent error: [Loading superclasses of GlobalVoucher]
    22.04.2013 14:30:43 Agent error: [Loaded InterTargetVoucher]
    22.04.2013 14:30:43 Agent error: [Loading superclasses of InterTargetVoucher]
    22.04.2013 14:30:43 Agent error: [Preparing TripBilling]
    22.04.2013 14:30:43 Agent error: [Loaded SAPConnectionParameter]
    22.04.2013 14:30:43 Agent error: [Loading superclasses of SAPConnectionParameter]
    22.04.2013 14:30:43 Agent error: [Preparing SAPConnectionParameter]
    usw.....




    Gruß


    Stephan

    Hallo zusammen,


    ich habe in einer mehrsprachigen XPage Anwendung folgendes Problem:


    In der Anwendung existieren property files für mehrere Sprachen. Im deutschen property file, das in der Anwendung als default-language eingestellt ist, befinden sich Umlaute. Diese Umlaute werden jedoch im Browser nicht korrekt dargestellt. Schreibe ich den Text mit den Umlauten hart in die XPage, so werden die Umlaute korrekt im Browser angezeigt.


    Ich hole mir die jeweiligen Sprachen und Texte über Java-Script Code:


    var message = resStrings["SameTimeAgreement"];
    var msg = I18n.format(message, context.getLocaleString());
    return (msg);


    Hat jemand von Euch eine Idee, wo das Problem liegen könnte?


    Gruß
    Stephan

    Danke für den Tipp. Ich habe ins Log geschaut, aber bin auch nicht wirklich schlauer geworden. Ich habe die Extension Library aber testhalber noch auf einem anderen System mit Notes 8.5.3 installiert und dort funktionierte es ohne Probleme. Ich denke, daß die die erste Notes Installation, mit der ich es probiert habe, fehlerhaft ist.
    Das Eclipse-Log habe ich als Screenshot mal beigefügt.

    Dateien

    • EclipseLog.JPG

      (52,02 kB, 11 Mal heruntergeladen, zuletzt: )

    Hallo liebe Notes/XPages Gemeinde,


    ich habe folgendes Problem und hoffe, jemand von Euch kann
    mir weiter helfen.


    Ich habe den Notes Client und Designer 8.5.3 im Einsatz und wollte mir
    die Extension Libraries für den Designer 8.5.3 von OpenNTF installieren.
    Ich habe gemäss Anleitung im Designer über "Application / Install" und
    anschliessend "Add Zip/Jar Location" das Paket "updateSiteOpenNTF-designer.zip"
    ausgewählt. Danach habe ich sämtliche Features ausgewählt, das License Agreement
    bestätigt und die Installation gestartet. Leider schlug sie jedes mal mit der
    unten angehängten Fehlermeldung fehl.


    Hat jemand eine Idee, was das Problem sein könnte? Ich habe schon im Netz
    recherchiert und leider keine Lösung gefunden.


    Gruß
    Stephan

    Dateien

    Hallo Wolfgang,


    Du kannst die Abfrage nach dem rteturnReceipt auch im QueryOpenDocument der Inbox durchführen. hat bei mir bisher anstandslos in allen Notes Versionen funktioniert:


    @If(@IsAvailable(ReturnReceipt);
    @If(ReturnReceipt = "1";
    @If(@Prompt([YesNo];"Hinweis"; "Der Absender der Mail hat eine Empfangsbestätigung angefordert. Wollen Sie diese senden?") = 0;
    @SetField("ReturnReceipt";"0");
    "");
    "");
    "")



    Gruß
    Stephan

    Hi,


    wenn Du die Mails im Sinne eines Backups nach Extern sichern möchtest, dann ist eine Backup Software der richtige Weg.
    Falls Du die E-Mails nur auf dem Domino Server archivieren möchtest, dann kannst Du das auch über die Archivierungsfunktion des Domino Servers mit Hilfe einer Policy und eines Programmdokuments machen.


    Gruß
    Stephan

    Hi,


    Du hast doch sicher eine Notes ID, die Du für die Administration des Domino Servers nutzt. Mit dieser ID im Domino Admin Client die Person im NAB auswählen, bei der das Problem mit der ID auftritt und anschliessend rezertifizieren. Dann sollte die Meldung nicht mehr kommen.


    Gruß
    Stephan

    Hi,


    hast Du mal probiert, die Ansicht zu löschen und komplett neu zu erstellen? Möglicherweise hilft das.
    Ich hatte auch einmal so ein Phänomen, da ließ es sich auf diese Weise lösen. Anscheinend war die Ansicht
    strukturell defekt, dieser Defekt wurde aber nicht mit repliziert.


    Gruß Stephan

    Hi,


    vielleicht mal mit einem Agenten probieren, der durch "After new mail arrives" Event getriggert wird. Die E-Mail aus SAP hat sicher immer den gleichen Aufbau und dann kannst Du den Inhalt mit dem Scriptagenten parsen und so die Kalendereinträge erstellen.